No announcement yet.

Having weird problems with only 2 certain USB devices

  • Filter
  • Time
  • Show
Clear All
new posts

  • Having weird problems with only 2 certain USB devices

    I'm having a really weird problem with a couple of my USB devices that really no explantions. And to just show I haven't left much open to overlooking something, I'm gonna explain everything I can in detail.

    First of all, I recently just reinstalled Windows XP in my computer again. I wanted to get rid of Windows Vista cuz it was annoying me with some of it's features. I had upgraded to windows vista from XP a few months back, cuz I wanted to see some games with direct X 10 support, but I didnt feel it was worth it anymore.

    Past couple days I've just been trying to get stuff I had in my computer back up and running, and one of those things is I happen to enjoy some games that use a game controller, like a PS2 one or XBOX. Since before I had vista, I've been using this PS2 controller to USB adapter I have, and more recently the microsoft wireless receiver for an xbox 360 controller. Both worked on XP and vista just fine for the time I used them.

    Now I've tried to get almost everything in my computer back to the way it was. I've updated windows, found drivers for stuff I knew I needed drivers for, including the 2 controller adapters I'm refering to.

    Now, just to put it simply, the problem I'm having with these devices is that they just don't get fed any power. The lights don't turn on at all when they're plugged, no bubble pops up saying "Found new hardware" and the computer acts like I didn't even plug anything in.

    I've plugged both devices into multiple USB slots on my computer, so it isn't just a problem with a single USB slot. I know my USB slots are working properly, because every other keyboard, mouse, webcam, digital camera, flash driver I've plugged into all of them still work as well. I also know for a fact that the devices themselves still work properly, because I took them both over to my dad's computer, and the popped up just fine as well! The lights turned on, and both of them appeared as new hardware on his computer.

    I've gone over the device manager, constantly seeing if there's something I'm missing, and it keeps saying that the devices are working properly. That is, the USB slots are working properly. It NEVER finds the ps2 adapter, or the xbox wireless receiver as accessible hardware, it does not recognize them being plugged AT ALL, EVER. Yet, if i unplug one of them, and plug something else in, like my jump drive, the very same USB slot will still work just fine. Won't be any delay, it'll pop up immediately.

    Also, bear in mind, that it's not like these USB don't have the ability to use these devices. They obviously put out the power output necessary for these devices, because i've used them before for a while.

    Anyway, in closing, this problem is just really stressing me out. I dunno if maybe I'm missing something. I've tried updating bios on my motherboard again, and looking at the available drivers for my motherboard as well, but I'm not finding anything usb related. It just says that as long as i got service pack 1 at least, i should have all my usb 2.0 support available to me, so there's really nothing left out. It feels like there's a conscious force working against me to prevent from using my game controllers on my PC, cuz these are the only devices not working.

    Hope someone can help, and if you have more questions on the matter first, feel free to ask. Thanks for reading.

  • #2
    Re: Having weird problems with only 2 certain USB devices

    Did you unplug any other usb devices and then try it? Could be a too much drain from other devices that you have plugged in. That happens to me a lot. Otherwise no idea here.
    Originally posted by Feba
    But I mean I do not mind a good looking man so long as I do not have to view his penis.
    Originally posted by Taskmage
    God I hate my periods. You think passing a clot through a vagina is bad? Try it with a penis.
    Originally posted by DakAttack
    ...I'm shitting dicks out of my eyeballs in excitement for the next bestgreating game of all time ever.


    • #3
      Re: Having weird problems with only 2 certain USB devices

      Like TGM says, it could be a power drain...I had a similar situation come up a couple builds everything hooked up and plugged in, and I kept losing my slave hard drive. After pulling my hair out (and formatting and reformatting the slave hdd) I finally determined that it was actually my web-cam that was killing the drive. When going through the IDE devices in the CMOS the hard drive was always there, sitting happily. but as soon as I got into Windows it was gone. Finally, after unplugging everything USB related except the keyboard and mouse and starting up, the hard drive was there. Thinking it fixed itself, I Plug in all the other USB devices, reboot, and it's gone again. From that point I would restart with the USB devices hooked up one at a time, and as soon as I got to the webcam, the slave drive would always be gone. It's weird how the computer would prioritize a webcam over a hard drive, but hey, this is Windows we're talking about ^^

      Anyways, I got a bigger power supply and my problem went away...but your mileage may vary, obviously.
      I'm a slow motion accident, lost in coffee rings and fingerprints...
      -Frou Frou, "Hear Me Out"

      Check out my blog! =>


      • #4
        Re: Having weird problems with only 2 certain USB devices

        I appreciate the responses and you guys trying to help so far, but no I can say that that's not it either.

        I've disconnected every USB device, including my keyboard and mouse, and used a standard keyboard and mouse, and it still would not read these devices.